Scheduled for August 09, 2024 at 4:30 AM – 6:00 AM
Completed
August 09, 2024 at 6:00 AMCompleted
August 09, 2024 at 6:00 AMMaintenance has completed successfully.
In progress
August 09, 2024 at 4:30 AMIn progress
August 09, 2024 at 4:30 AMMaintenance is now in progress
Planned
August 09, 2024 at 4:30 AMPlanned
August 09, 2024 at 4:30 AMThe development team will be conducting maintenance on the Flight School Website for around the next 2 hours. The site will be unavailable during this time. Please save any work that you are currently working. We will update you when the site it back up and running.