Scheduled for June 11, 2025 at 11:22 AM – 12:16 PM
Affects
Flight School Website
Under maintenance from 11:22 AM to 12:16 PM
Completed
June 11, 2025 at 12:16 PMCompleted
June 11, 2025 at 12:16 PMMaintenance has completed successfully.
In progress
June 11, 2025 at 11:22 AMIn progress
June 11, 2025 at 11:22 AMMaintenance is now in progress
Planned
June 11, 2025 at 11:22 AMPlanned
June 11, 2025 at 11:22 AMWe are performing updates on the flight school at this time. The site will be down during these updates. Please check back later for further information